Slow download rates from CloudLinux mirrors in the EU regions

Incident Report for CloudLinux

Resolved

This incident has been resolved
Posted May 22, 2026 - 07:26 UTC

Monitoring

Infrastructure adjustments have been made, and we're keeping an eye on the situation
Posted May 14, 2026 - 05:42 UTC

Investigating

We are experiencing issues with download speed from mirrors in the EU region. It may cause slow download rates and timeouts during yum updates:

1. Repodata metadata returning 404:
Status code: 404 for https://rollout-ng.cloudlinux.com/slot-8/8/x86_64/repodata/-primary.xml.gz
Error: Failed to download metadata for repo 'cloudlinux-rollout-8'
2. Slow / timed-out RPM transfers:
Curl error (28): Timeout was reached for https://rollout-ng.cloudlinux.com/slot-1/10/x86_64/.rpm [Operation too slow. Less than 51200 bytes/sec transferred the last 30 seconds]

This issue is currently being investigated by our infrastructure team under task REAIT-564. Further updates will be shared as soon as progress is made.
Posted May 13, 2026 - 20:23 UTC